Polyphony: インストール
polyphony
2019-3-12 23:35 JST

Python のバージョン

Polyphony は Python のバージョン3 で動作します。手元の python のバージョンを確認してみましょう。多くの場合 python3 が Python のバージョン3です。(python2 はバージョン2です。単純に python でも多くの場合は バージョン 2でしょう)

$ python3 --version
Python 3.6.7

pip3 は入ってますか?

Python には pip という便利なインストールツールがあります。python3 がインストールされているなら pip3 が入っている事でしょう。ubuntu なら apt でインストール可能です。

apt install python3-pip

pip3 からのインストール

pip3 があれば Polyphony のインストールは簡単です。

$ pip3 install polyphony
$ polyphony -V
polyphony 0.3.5

polyphony -V (大文字の V) でバージョンを確認できます。

もうHDLで複雑な状態マシンを書く必要はありません。

さらに進んだ話題

Polyphony を現在の実機に直接インストールしたくない(できない)という場合などでは Python の venv というバーチャルな環境を構築することで解決します。venv も使い方は簡単です。詳細は次のリンク先を参照してください。

venv をつかって Polyphony を複数バージョンインストールする